
BetterSolutions.comBetterSolutions.comBetterSolutions.comBetterSolutions.com    
Tutorials and AddTutorials and AddTutorials and AddTutorials and Add----ins for Microsoftins for Microsoftins for Microsoftins for Microsoft    Excel, Word and PowerPointExcel, Word and PowerPointExcel, Word and PowerPointExcel, Word and PowerPoint    
 

Copyright © Better solutions Limited. All Rights Reserved. Page 1 of 8 
No part of this publication can be published or reprinted without explicit written permission from Better Solutions Limited 

AugustAugustAugustAugust    2009200920092009    ----    Letter from the EditorLetter from the EditorLetter from the EditorLetter from the Editor    
Welcome to the ninth edition of the BetterSolutions.com newsletter. Our last newsletter was over twelve 

months ago so there is a lot to catch up on. We have got plenty of new content planned with a clear focus on 

updating the website to include more 2007 screenshots and examples. There will also be a concerted effort to 

improve the documentation on the following subjects: XML, Analysis ToolPak, Pivot Tables and Charts as well 

as hopefully uploading whole sections on Access and SharePoint in the near future. We have also started 

building a dedicated Finance section which is helping us to understand and document all the financial 

worksheet functions. This issue contains an article on expanding column widths, examples of the RATE and 

IRR functions as well as a summary of the Excel 2007 View tab. 

Formula AutoCompleteFormula AutoCompleteFormula AutoCompleteFormula AutoComplete    
One of the most noticeable changes in Excel 2007 is the new formula auto complete and the additional 

tooltips. This makes it a lot easier to enter your formulas because it displays a list of all the available functions 

and range references. As soon as you start typing the auto complete will display a list of functions starting with 

those particular letters. As you can see from the screen shots the auto complete does not only contain built-in 

worksheet functions but also displays user defined functions, named ranges, table names as well as function 

enumerations. The items in the auto complete list are always displayed in ascending alphabetical order and 

different icons are used to identify the different objects. Another new feature in Excel 2007 is the ability to 

associate comments with your named ranges and tables. The comments will be displayed automatically as a 

tooltip when that named range or table name is highlighted. 

support@bettersolutions.comsupport@bettersolutions.comsupport@bettersolutions.comsupport@bettersolutions.com    
This email address is the one you should use when you have any problems or questions with Microsoft Office 

and you want some FREE help and advice. Sending us your questions will not only mean that you get a reply 

quickly but will also allow us to publish the answers in the next issue which will help other people as well. We 

spend a lot of time checking and testing the information to ensure that it is accurate but if you do spot any 

mistakes or anything that is wrong then please tell us. We are always looking for ways to improve our 

products and services and always welcome constructive criticism. 
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News and Related InformationNews and Related InformationNews and Related InformationNews and Related Information    

Genuine Genuine Genuine Genuine Microsoft SoftwareMicrosoft SoftwareMicrosoft SoftwareMicrosoft Software    
Software written and distributed by Microsoft and its partners is properly licensed and fully supported by 

Microsoft. However there is a lot of software in the market today that is not genuine. To help Microsoft 

distinguish between its own software and counterfeit software most of its applications and operating systems 

have to be registered after they have been purchased. This validation process not only reassures you that the 

software you are using is genuine but also ensures you will receive all the latest updates and ongoing 

improvements. Microsoft Office has a built-in component called Office Genuine Advantage (OGA) which 

requires you to activate your software either online or over the telephone. You will be reminded to activate 

the first time you open a Microsoft Office application and you must activate your copy within the first 25 

launches for Office 2007. For Office 2003 and Office XP you must activate within the first 50 launches. 

Activation is extremely easy and will take you less than a minute to complete. Once completed you will be 

able to download lots of FREE add-ins, templates, tools and updates straight from the Microsoft Office Online 

website. You will need to repeat the validation process if Office is reinstalled. You can validate your copy of 

Office by visiting the following web page: http://www.microsoft.com/genuine/office/validate.aspxhttp://www.microsoft.com/genuine/office/validate.aspxhttp://www.microsoft.com/genuine/office/validate.aspxhttp://www.microsoft.com/genuine/office/validate.aspx    

 

You may also have come across the Windows Genuine Advantage (WGA) program. This is very similar to the 

OGA but applies to your Windows operating systems. You will be prompted to validate your copy of Windows 

if you want to download anything from the Microsoft Download Centre. The validation process is very simple 

and will only take a couple of minutes. Once completed you will be able to download service packs and 

general updates straight from the Microsoft website. You will need to repeat the validation process if Windows 

is reinstalled. You can validate your copy of Windows by visiting the following web page: 

http://www.microsoft.com/genuine/validate/http://www.microsoft.com/genuine/validate/http://www.microsoft.com/genuine/validate/http://www.microsoft.com/genuine/validate/    

http://technet.microsoft.comhttp://technet.microsoft.comhttp://technet.microsoft.comhttp://technet.microsoft.com    
This site contains all the latest information and articles about Microsoft products and technologies and has 

been designed as a resource for IT professionals. It includes: virtual labs, webcasts, downloads, forums etc. 

The website is divided into several sections.  

LibraryLibraryLibraryLibrary – Lots of technical documentation covering all the different products. There is an Office section 

relating to Microsoft Office 2007 but the information here is more relevant for a system administrator. 

LearnLearnLearnLearn – This includes details about different training resources and certification. 

TroubleshootingTroubleshootingTroubleshootingTroubleshooting – This is linked to the Support Knowledge Base.  

CommunityCommunityCommunityCommunity – Contains lots of blogs, forums including a monthly newsletter. 

DisclaimerDisclaimerDisclaimerDisclaimer    
Better Solutions Limited is in no way associated with Microsoft Corporation. All the content in this newsletter 

and on the website is provided “as is” with absolutely no warranties. We strongly recommend that you back up 

all your data first before installing any updates or third party software. In no event shall Better Solutions 

Limited be liable for any special, indirect or consequential damages whatsoever resulting from loss of use, data 

or profits, whether in an action of contract, negligence or other action arising out of or in connection with any 

information published in this newsletter or on our website. 
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Your Questions and ProblemsYour Questions and ProblemsYour Questions and ProblemsYour Questions and Problems    
Excel Excel Excel Excel ––––    How can I add How can I add How can I add How can I add ““““stststst””””, , , , ““““ndndndnd””””, , , , ““““rdrdrdrd””””    and and and and ““““thththth””””    to the end of my numbers?to the end of my numbers?to the end of my numbers?to the end of my numbers?    
It is possible to add ordinals to your numbers (to create 1st, 2nd, 3rd, 4th etc) by using built-in worksheet 

functions. The formula you need to use is quite complicated and uses the following five functions: IF, OR, 

VALUE, RIGHT and CHOOSE. This can be seen in cell “B8”. Most of the ordinal values need a “th” on the end 

although there are a few exceptions. If the number has a 1 at the end then it needs a “st”. If the number has a 2 

at the end then it needs a “nd”. If the number has a 3 at the end then it needs a “rd”. 

 
 

Excel Excel Excel Excel ––––    WWWWhat is the correct format for external workbook rhat is the correct format for external workbook rhat is the correct format for external workbook rhat is the correct format for external workbook referenceseferenceseferenceseferences????    
When you include external workbook references in your worksheets they will have a very specific syntax. If 

either (or both) the WorkbookName or the WorksheetName contain spaces then these must be enclosed in 

single quotation marks. If the workbook is closed (or cannot be found) then the FolderPath will also be 

included. When the folder path is included the FolderPath, WorkbookName and WorksheetName are always 

enclosed in single quotation marks. 

 

EEEExcel xcel xcel xcel ––––    How can I install an addHow can I install an addHow can I install an addHow can I install an add----in in in in for everyonefor everyonefor everyonefor everyone????    
The (Tools > Add-ins) dialog box or (Office > Excel Options)(Add-ins tab) in Excel 2007 lets you see what 

add-ins are available and to control which ones are loaded. These settings are user specific which means that 

when different users log on to the same computer they could see different add-ins. If you have a third party 

“.xla” add-in that you want installed and made available to anyone who logs on to that computer then you 

need to save your add-in in the following folder: 

Excel 2007Excel 2007Excel 2007Excel 2007: C:\Program Files\Microsoft Office\Office12\Library\ 

Excel 2003Excel 2003Excel 2003Excel 2003: C:\Program Files\Microsoft Office\Office11\Library\ 

Excel 2002Excel 2002Excel 2002Excel 2002: C:\Program Files\Microsoft Office\Office10\Library\ 

 

Excel Excel Excel Excel ––––    Why do my URLs automatically become hyWhy do my URLs automatically become hyWhy do my URLs automatically become hyWhy do my URLs automatically become hyperlinks?perlinks?perlinks?perlinks?    
Any hyperlinks or internet URLs you enter in a worksheet 

will be automatically changed into hyperlinks by default. 

For those of us that find this really annoying you can turn 

this off from (Tools > AutoCorrect Options)(AutoFormat 

as you type tab) or (Office > Excel Options)(Proofing tab) 

in Excel 2007. 



August 2009 support@bettersolutions.com 

Copyright © Better solutions Limited. All Rights Reserved. Page 4 of 8 
No part of this publication can be published or reprinted without explicit written permission from Better Solutions Limited 

Expanding Expanding Expanding Expanding Column WidthsColumn WidthsColumn WidthsColumn Widths    
You may not have noticed but your column widths often expand automatically when you enter or format 

certain values. A column width will expand automatically when the cell has been formatted with the 

“General” number format and you enter or edit a particular value. A column width can also expand when you 

are changing the number format. Column widths are not automatically adjusted when data is copied or moved. 

The default column width in a new worksheet is 8.43. 

NumbersNumbersNumbersNumbers    
All numbers are stored with a precision of 15 significant digits. If you enter more than fifteen significant digits 

the extra digits are converted to zero automatically (i.e. the number is rounded down). Numbers with less than 

9 digits are displayed in full. Numbers with 9 or 10 digits are displayed in full and have the column width 

increased. Numbers with more than 11 digits are displayed in scientific notation and have the column width 

increased. Numbers with more than 15 digits are rounded down, displayed in scientific notation and have the 

column width increased.  

 

DecimalsDecimalsDecimalsDecimals    and Fractionsand Fractionsand Fractionsand Fractions    
Numbers entered with decimals also increase the column width when they have more than 7 decimals. 

Numbers with more than 9 digits are displayed in scientific notation. Numbers containing fractions could also 

cause the column width to increase automatically. Fractions with more than 15 digits are rounded down and 

displayed with no fraction. The same is true for numbers entered with commas, dollar signs, or percent signs. 

 

DatesDatesDatesDates    
Entering and editing dates can also cause the column width to increase automatically. Be aware that the date 

displayed is not always the same and is dependent on the format that is entered. 
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Function Function Function Function ––––    RATERATERATERATE 

The arguments for this function are: RATE(nper, pmt, pvRATE(nper, pmt, pvRATE(nper, pmt, pvRATE(nper, pmt, pv    [,fv][,fv][,fv][,fv]    [,type][,type][,type][,type]    [,guess][,guess][,guess][,guess])))) 

This function returns the interest rate for a series of equal cash flows at regular intervals. This function can be 

used to calculate the interest rate of an annuity. An annuity is when fixed payments are made at regular 

intervals. 

• the interest rate returned is based on the period specified. 

• the interest rate returned is compounded according to the period specified. For example if your 

repayments/deposits are made yearly then the interest rate will be a yearly compounded interest rate. If 

your repayments/deposits are monthly then the interest rate will be a monthly compounded interest rate. 

• each payment is made at the end of the period, unless the ‘type’ argument is set to 1. 

• all the arguments must be expressed in the same unit of time (years, months, days etc). 

• the interest is assumed to be re-invested immediately at the same rate. 

 

For those of you who are not familiar with compound interest it refers to adding the accumulated interest to 

the principal amount so that you can earn interest on the interest you have already accumulated. Most interest 

is compounded but when it isn’t it is referred to as simple interest. 

Loan repaymentsLoan repaymentsLoan repaymentsLoan repayments    and sand sand sand saving depositsaving depositsaving depositsaving deposits    
What interest rate have you been charged if you pay off a 

£400 loan in 2 years making annual payments of £300 at the 

end of each year? The number of periods is 2. The fixed 

repayment is -300 since we are repaying £300 every year. 

The minus sign indicates that the £300 is cash you are paying 

out. The original loan amount is 400 and the final balance is 

0 as the loan is being paid off. The interest rate returned will 

be a yearly interest rate, that is compounded yearly. 

What interest rate have you received if you deposit 

£200 at the start of each year and after 3 years you have 

£800? The number of periods is 3. The fixed deposit is 

-200 since we are depositing £200 every year. The 

opening balance is 0 since there is no upfront amount 

in the savings account. The final balance is 800 since 

we have accumulated £800 at the end of the 3 years. 

The payment type is 1 indicating that the payments are made at the start of each period. The interest rate 

returned will be a yearly interest rate, that is compounded yearly. 

 

What interest rate would you need if after 8 years of 

depositing £120 a month you wanted to have saved £20,000, 

starting with an initial deposit of £600? As payments are 

made monthly all the arguments need to be in monthly 

denominations. The number of periods is 96 (8 x 12). The 

fixed deposit is -120 since we are depositing £120 a month. 

The opening balance is 600 since you have an initial deposit 

of £600. The final balance is 20,000 because we want to 

have accumulated £20,000 at the end of the 8 years. The interest rate returned will be a monthly interest rate 

compounded monthly. Multiplying the interest rate by 12 will give you a yearly interest rate, that is 

compounded monthly. 
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Function Function Function Function ––––    IRRIRRIRRIRR    
The arguments for this function are: IRR(values [,guess])IRR(values [,guess])IRR(values [,guess])IRR(values [,guess]) 

This function returns the interest rate for a series of equal or unequal cash flows at regular intervals. This 

function can also be used to calculate the interest rate of an annuity. This function is slightly more advanced 

than the RATE() function because it has the ability to handle both equal and unequal cash flows at regular 

intervals. 

• the interest rate returned is always a yearly interest rate. 

• the interest rate returned is always compounded yearly. 

• each payment is made at the end of the period. 

• there must be at least one positive payment and one negative payment. 

• the interest is assumed to be re-invested immediately at the same rate. 

• the order of the payments is very important, so make sure they are in the correct order. 

Loan repayments and saving depositsLoan repayments and saving depositsLoan repayments and saving depositsLoan repayments and saving deposits    
What interest rate have you been charged if you pay off a £400 

loan in 2 years making annual payments of £300 at the end of 

each year? There are three cash flows that have to be considered. 

The original amount borrowed and then the two repayments. 

The minus sign indicates that the £300 is cash you are paying 

out. The interest rate returned is a yearly interest rate, 

compounded yearly. This interest rate is the same as that 

returned from the RATE() function on page 5. 

 

What interest rate have you received if you deposit £200 at the 

start of each year and after 3 years you have £800? There are 

four cash flows that have to be considered. The interest rate 

returned is a yearly interest rate, compounded yearly. This 

interest rate is the same as that returned from the RATE() function on page 5. 

 

What interest rate have you been charged if you pay off a £500 

loan in 3 years? Making a payment of £250 at the end of the first 

year, a payment of £350 at the end of the second year and a 

payment of £150 at the end of the third year. There are four 

cash flows that have to be considered. This interest rate could 

not have been calculated using the RATE() function because the 

cash flows are unequal. 

 

Guess argumentGuess argumentGuess argumentGuess argument    
In most cases you will not have to provide a guess because the default value which is 0.1 (or 10%) is sufficient. 

In some situations there may be more than one possible interest rate in which case using a different guess can 

result in a different interest rate. This function uses an iterative technique to calculate the interest rate. If a 

result cannot be found after 20 iterations then #NUM is returned. 

 

This function is often described as the “discount rate that generates a zero net present value”. The interest rate 

returned by this function is calculated using the NPV() function iteratively calculating the interest rate that 

will give a NPV of zero. 



August 2009 support@bettersolutions.com 

Copyright © Better solutions Limited. All Rights Reserved. Page 7 of 8 
No part of this publication can be published or reprinted without explicit written permission from Better Solutions Limited 

Excel 2007 Excel 2007 Excel 2007 Excel 2007 ––––    ViewViewViewView    TabTabTabTab    
At a quick glance all of these commands will look familiar 

however there are several new features hidden amongst 

them. The new Page Layout is one of the biggest changes. 

The Macros group may seem a little out of place at first but 

this functionality is not to be confused with the Developer 

tab. The Macros drop-down only allows you to view and 

run macros that are currently available. 

 

Workbook ViewsWorkbook ViewsWorkbook ViewsWorkbook Views    
This group contains all the commands relating to the different ways 

you can display your worksheets or workbook. The Normal view 

and the Page Break Preview view are the familiar (View > Normal) 

and (View > Page Break Preview) commands. The Page Layout 

view is a new feature which makes it a lot easier to see what your 

worksheet will look like when it is printed. It is important to realise that this is a fully editable view. Anything 

you can do in the Normal view you can also do in this view. There are also new shortcuts to these 3 different 

views in the bottom right corner next to the status bar. The “Custom Views” command displays the old (View 

> Custom Views) dialog box. This command is not available when the active workbook contains any tables. 

The “Full Screen” is the old (View > Full Screen) and instead of displaying an annoying toolbar to help you 

back to the normal screen you can just press the ESC key. The only way to display your workbook in print 

preview is to use (Office > Print > Print Preview) or to use the Quick Access toolbar. 

 

Show/HideShow/HideShow/HideShow/Hide    
The Show/Hide group contains some of the application and worksheet 

specific commands that were previously found on the View drop-down menu 

and in the (Tools > Options) dialog box. The “Ruler” checkbox is a new 

feature that allows you to toggle the display of the ruler when displaying a 

worksheet in Page Layout view. The “Gridlines” checkbox  toggles the 

display of gridlines on the active worksheet and is from the (Tools > Options)(View tab) under the Window 

Options heading. The “Message Bar” checkbox is a new feature which replaces all pop-up messages. For 

example if macros have been disabled you won’t see the annoying ‘macros are disabled’ popup but instead you 

will see a message appear in between the ribbon and the formula bar. This checkbox allows you to toggle the 

display of these messages. The “Formula Bar” checkbox toggles the display of the formula bar and is from the 

View drop-down menu and the (Tools > Options)(View tab) under the Show heading. The “Headings” 

checkbox is from the (Tools > Options)(View tab) and toggles the display of the row & column headers. These 

are now a bit easier to access but I am disappointed not to see a checkbox for “Show Page Breaks” or “R1C1 

Notation”. Show Page Breaks can only be accessed from (Office > Excel Options)(Advanced tab) and then 

scrolling to the “Display options for this workbook”. R1C1 Notation can only be accessed from the (Office > 

Excel Options)(Formulas tab). You can no longer toggle the display of the status bar. 

    
ZoomZoomZoomZoom    

This group contains commands that relate to adjusting the display percentage of the 

active worksheet. The “Zoom” command is the familiar (View > Zoom). The “100%” 

command lets you quickly return to a view of 100%. The “Zoom to Selection” 

command is a new feature and lets you quickly zoom into the current selection. 

There is also a new zoom slider in the bottom right corner, next to the status bar. 
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WindowWindowWindowWindow    
This contains commands 

relating to workbooks. 

Every workbook you open 

in Excel can be thought of 

as a window. It is also 

possible to open multiple windows of the same workbook. The “New Window” command is the old (Window 

> New Window) which creates a new window of the active workbook. The “Arrange All” command is the old 

(Window > Arrange) which displays the Arrange Windows dialog box and lets you arrange the open windows 

in different ways. The “Freeze Panes” drop-down applies to the active worksheet and displays the options: 

freeze panes, freeze top row and freeze first column. The freeze panes command is the old (Window > Freeze 

Panes) and the other two are new. The “Split” command is the old (Window > Split) which inserts a split into 

the active window. The “Hide” command is the old (Window > Hide) which hides the active window. The 

“Unhide” command is the old (Window > Unhide) which displays the Unhide dialog box allowing you to 

unhide previously hidden windows. 

 

The “View Side by Side” command is the old (Window > Compare Side by Side) allowing you to scroll both 

windows together. The “Synchronous Scrolling” command allows you to toggle the synchronous scrolling on 

and off and is only available when you are viewing windows side by side. This was previously found on the 

Compare Side by Side toolbar. The “Reset Window Position” command will reset the position of the windows 

to be arranged horizontally which is useful if the windows have been moved or resized. This is also only 

available when you are viewing windows side by side. This was previously found on the Compare Side by Side 

toolbar. The “Save Workspace” command was previously available by displaying the (File > Save As) dialog box 

and changing the file type to workspace. The “Switch Windows” drop-down displays all the workbooks that 

are open in that particular session. In Excel 2003 this was displayed at the bottom of the Window menu. The 

quickest way to jump between your windows though is to use the (Ctrl + Tab) shortcut key. 

 

MacrosMacrosMacrosMacros    
This group is displayed by default and is not related to whether the Developer tab is displayed or 

not. This drop-down button contains the options: commands view macros, record macro and use 

relative references. These have all been taken from the Visual Basic toolbar and (Tools > Macro) 

submenu. None of this functionality has changed. Pressing the button above the drop-down arrow is 

a shortcut to the view macros command. This displays the familiar (Tools > Macro > Macros) dialog 

box. The “Record Macro” command lets you record your steps so it can be played back later. The use relative 

references command allows you to toggle between recording absolute cell references or relative cell 

references. This is also from the Visual Basic toolbar and Macro submenu. These three commands are more 

than sufficient for those of us who just record a macro and then need to run it. If you want to edit macros or 

do anything more complicated then you should have the Developer tab displayed as well. The Developer tab 

contains additional commands relating to Visual Basic and can be displayed by selecting (Office > Excel 

Options)(Popular tab, “Show Developer tab in Ribbon”). 

 

View Tab SummaryView Tab SummaryView Tab SummaryView Tab Summary    
The best new feature is definitely the new Page Layout view. Any pages that will not be printed will be 

displayed in grey making it very easy to see what will be printed before it is printed. Using the Page Layout 

view in combination with the new zoom slider lets you quickly see how all of your information fits across 

multiple pages. This view is very similar to the Print Layout view in Word 2007. 


