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October 2010 - Letter from the Editor
Welcome to the tenth edition of the BetterSolutions.com newsletter. And yes the last one we wrote was
August 2009. The reason it has been so long is because we have been focusing our attention on building a
dedicated VBA section for the website and complements the three existing sections very well. This includes a
detailed list of all the built-in subroutines and functions as well as lots of code snippets. In this issue we are
going to focus on Word templates. We hope to clarify the different types, the best place to save them and the
easiest way to keep them updated. For those of you who use Excel, the ideas and methods discussed regarding
sharing and updating can easily be applied to Excel as well. As you can imagine we get a lot of people
contacting us with a wide variety of questions, some simple and some more complicated. We will always try to
reply to your questions within a few days but sometimes it can take longer.

Dedicated VBA Section
A new section focused entirely on VBA is
now available. This can be accessed from the
home page and has the following URL:
http://www.bettersolutions.com/vba.aspx.
I hope you all visit this new section and find
it useful. This section will eventually be
fully integrated with an additional link
appearing at the top of every page. Please
keep sending us your comments and
feedback.

What is SharePoint?
SharePoint?
Most users have to use a variety of systems, some accessed online and others installed locally. The complexity
of these systems and the lack of integration mean that most of us have a frustrating relationship with our
computers. You often need a different password for each system which you find difficult to remember and are
frequently phoning the helpdesk when your computer isn't working. You receive hundreds of emails a day
which you keep for reference but are too busy to read and instead of your day getting easier, each new release
seems to make things more complicated. The key to solving this problem is to create a user experience that
simplifies how we access all our information. The answer is SharePoint.
SharePoint is a web based tool that allows people to save and display different types of information all in one
place. SharePoint enables you to share documents, e-mails, lists, calendars, etc and is very tightly integrated
with Microsoft Office. This integration is so significant we are considering building a dedicated section on the
website specifically for it. We briefly discussed Windows SharePoint Services (version 3) in the May 2008
issue so to help us to recap here is a quick summary of all the different versions and when they were released:
Version 1 - Microsoft SharePoint Team Services released Mar 2001
Version 2 - Windows SharePoint Services 2.0 released Dec 2003 in conjunction with Office 2003
Version 3 - Windows SharePoint Services 3.0 released Feb 2007 in conjunction with Office 2007
Version 4 - SharePoint Foundation 2010 released May 2010 in conjunction with Office 2010
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News and Related Information
Ribbon Hero
Ribbon Hero is a learning/training add-in created by Microsoft for people who are using Office 2007 or 2010.
It is designed to help you become more familiar with the Ribbon interface and help you find new and existing
functionality. It has been designed very much like a game, in an attempt to bring some interactive fun to your
day-to-day. The add-in works with Excel, Word, PowerPoint and OneNote. Each application has a specific set
of challenges and you are awarded points for completing particular tasks. Doug Thomas has created a great
introduction video and you can download this add-in from the Office Labs website:
http://www.officelabs.com/projects/ribbonhero/Pages/default.aspx

Once installed, it appears as a single button in an additional group on the Home tab. A challenge will be
displayed the first time you open an application and after that you just hit the Ribbon Hero button to view
another challenge. We weren’t sure what to make of this as the reviews seemed to be mixed. But after
installing it and completing some of the challenges we really like it. It is very easy to use and is not intrusive at
all. It is fair to say that this does actually feel like a game in the sense that it is quite addictive. The best feature
has to be when the two balloons pass through the task pane.

support@bettersolutions.com
This email address is the one you should use when you have any problems or questions with Microsoft Office
and you want some FREE help and advice. Sending us your questions will not only mean that you get a reply
quickly but will also allow us to publish the answers in the next issue which will help other people as well. We
spend a lot of time checking and testing the information to ensure that it is accurate but if you do spot any
mistakes or anything that is wrong then please tell us. We are always looking for ways to improve our
products and services and always welcome constructive criticism.
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Office Business Application (OBA)
OBA is the term used when a Microsoft Office application contains an interface to a third party enterprise
system. This term is frequently used to describe applications that are designed to help businesses unlock the
potential of their internal systems. Creating an Office Business Application will often make your application
more accessible and easier to use because users are already familiar with the Microsoft Office interface. This
can be useful if you have internal systems that have very bespoke or complicated interfaces. For example
instead of Outlook just showing you emails and meetings you could write an Outlook Business Application
that could display useful HR information as well. Office Business Applications can encompass a huge range of
technologies. In addition to third party (non Microsoft) applications they sometimes also include other
Microsoft technologies, such as: SharePoint, SQL Server, Exchange, BizTalk, Groove, etc. Third party
applications are sometimes referred to as Line of Business applications or LOB for short.

Microsoft Office 2010 Versions
This is a summary of the different versions that are available for Office 2010.
Starter – This replaces the earlier Microsoft Works applications and will be pre-installed or most new PCs.
This includes Excel and Word with some of the advanced features excluded. There are four tabs instead of the
usual seven and will also contain a small amount of advertisements.
Home and Student – This includes Excel, Word, PowerPoint and OneNote.
Home and Business – This includes Excel, Word, PowerPoint, Outlook and OneNote.
Standard – This includes Excel, Word, PowerPoint, Outlook, OneNote and Publisher.
Professional – This includes Excel, Word, PowerPoint, Outlook, OneNote, Publisher and Access. Professional
Academic and Professional Plus contain the same applications but just have slightly different pricing models.
Office Web Apps – These are light weight web browser versions of Excel, Word, PowerPoint and OneNote.
Office Mobile – These are cut-down versions of the Excel, Word, PowerPoint, Outlook and OneNote. This is
FREE but is only available on phones that run Windows Mobile 6.5 or later.
Compared to the versions that were available in Office 2007 (March 2007 issue) this is a much simpler list.
With only 5 different suites to choose from, it is a lot easier to identify which one is right for you.

Disclaimer
Better Solutions Limited is in no way associated with Microsoft Corporation. All the content in this newsletter
and on the website is provided “as is” with absolutely no warranties. We strongly recommend that you back up
all your data first before installing any updates or third party software. In no event shall Better Solutions
Limited be liable for any special, indirect or consequential damages whatsoever resulting from loss of use, data
or profits, whether in an action of contract, negligence or other action arising out of or in connection with any
information published in this newsletter or on our website.
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Your Questions and Problems
Word – Can I get a prompt
prompt before my Normal template
template is updated?
Whenever you make any changes to your default settings these are saved in your Normal template. There are a
wide variety of default settings in Word which you can change. Two of the most common ones are your
default font and your default language. Your default font can be changed from the Font dialog box by pressing
the Default button and your language can be changed from the Language dialog box also by pressing the
Default button.
It is possible to receive notification whenever changes have been made to your Normal template. In all the
versions this prompt is switched off by default but it is very easy to switch it on. On the Word Options,
Advanced tab there is an option called “Prompt before saving Normal template”. Make sure this is ticked.

With this option switched on you will get the following prompt whenever changes have been made. This
appears after the documents have been closed but before Word exits. From now on every time your Normal
template is changed, either as a result of your own action, a consequence of an add-in or built-in functionality
you will have a choice of whether to save the changes or not.

If you are unable to save changes to your Normal template then it may be that your template has been opened
as read-only.

General - Are you going to create Outlook or Access sections for the website?
Yes. They are both in the pipeline but are a long way off from being uploaded. We often receive suggestions
on how to improve the website and recognise that these would be useful additions.

General - Are you going to update the design of the website?
Yes. The simple design and layout of the website is key to its speed and quick navigation but we do have plans
to update it. We are busy working on a new style sheet at the moment as well as building new pages.
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Word Template and Document Relationship
Every Word document is based on a template and every Word document has a template permanently attached
to it. When you create a new document the template used is attached automatically. When you create a blank
document the template used will be your Normal template. At this point it is important to appreciate that
Excel templates and Word templates behave slightly differently. In Excel everything from the template is
passed to the workbook. However in Word, this is not the case.

What is passed
passed to the Word document?
ocument?
When you create a document the following items are copied from the template and passed to the document.
Styles – All the styles that are available in the template.
Content – Any content that has been saved in the template, any sample text, tables, headers, footers, etc.
Page Layout – The page setup and layout of all the pages. This includes margins, paper size, and page
orientation.
All of these items are copied to the document (from the template) when the document is created.

What isn’t passed
passed to the Word document?
ocument?
When you create a document the following items are not passed to the document.
Macros – Any macros or macro project items. These include code modules, class modules or userforms.
User interface customisations – Any additional toolbars or menus.
Keyboard shortcuts – Any keyboard shortcuts that have been overwritten or assigned to macros.
Auto
Auto text /b
/building blocks – All built-in or user defined auto text or text snippets.
None of these items are copied to the document (from the template) when the document is created.
When you create a new document the template stays attached so these items can be accessed.

What Template is attached to this document?
document?
Every Word document has a template permanently attached
to it. To find out what template is attached to a document you
can display the “Templates and Add-ins” dialog box. In Word
2003 this is displayed by selecting (Tools > Templates and
Add-ins)(Templates tab). The name of the template is
displayed at the top, under document template.
In Word 2007 and 2010 this dialog box can only be accessed
from the Developer tab by selecting “Document Template”
from the Templates group. This tab will not appear by default
but can be displayed by selecting Word Options,
Popular/General tab and then ticking the option “Show
Developer tab in the ribbon”.

Only documents created from the Normal template are linked to the Normal template. If you create a
document using any other template then your document has absolutely no links (or ties) to the Normal
template.
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Different Word Templates
A template is a special type of document that should be used when you want to create several documents all
with a consistent look and feel. All templates contain specific settings relating to the styles, content, page
layout, macros, user interface customisations, keyboard shortcuts and auto text. Word provides a large
selection of built-in templates but if you still can’t find the right one then there are plenty more available on
the Office Online website. Before we discuss the different types, below is a list of the associated file extensions:
.dotx – Templates in Word 2010 and 2007 with no VBA macros
.dotm – Templates in Word 2010 and 2007 that contain VBA macro code
.dot – Templates in Word 97-2003 with or without VBA macros

Normal Template
This is the most important template out of all of them and should never be shared. This template should
always exist locally on the C drive. If there are any copies saved on shared drives then they should be removed
to avoid confusion. This template may not exist if a user has a clean install of Microsoft Office or has not made
any changes to their personal settings. This template is a special example of a user template and therefore is
always saved in the User Templates folder.
Location:
Location Always saved in the “User Templates” folder.

User Templates
A user template is a template that is saved locally on the C drive and can only be accessed by that individual
user. Any template saved in this folder will automatically appear in the New dialog box. This location must
never be changed to a shared drive as the user’s Normal template is saved in this folder when changes are
made. This location defaults to the C drive.
Location:
Location C:\Documents and Settings\”username”\Application Data\Microsoft\Templates\

Workgroup Templates
A workgroup template is a template that is shared across a team or company. Any template saved in this folder
will automatically appear in the New dialog box. This location defaults to not being set but should be changed
to point to a shared drive when you have company templates that you want a group of users to access.
Location:
Location S:\Shared Folder\Workgroup Templates\

Startup Templates
These are templates that are permanently loaded and are available whenever Word is open. They are often
referred to as global templates but they should really be thought of as add-ins rather than templates. In most
situations there is normally only one startup template. This location defaults to your C drive but should be
changed to point to a shared drive when the template needs to be shared by a group of users.
Default:
Default C:\Documents and Settings\”username”\Application Data\Microsoft\Word\STARTUP\
Location:
Location S:\Shared Folder\Startup Templates\

BuiltBuilt-in Templates
These are templates that are saved locally on the C drive and are installed by default when Word is installed.
Any templates saved in this folder will automatically appear in the New dialog box.
Location:
Location C:\Program Files\Microsoft Office\Templates\1033\
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Saving Shared Templates
Any templates that are not specific to an individual user should be saved on a shared drive (i.e. your
workgroup templates and startup templates). Once you have identified a shared drive that all your users can
access, create a folder called “Company Word Templates”. This should be a folder which everyone can access
but only a few administrators have permission to edit. This folder should contain two subfolders, one for your
workgroup templates and one for your startup templates. Create these two subfolders, see screenshot below.

Workgroup Templates
These are templates that are
accessed on demand as and
when users need them. They
are accessible from the New
dialog box and are for general
tasks, like creating letters, faxes,
memos, etc. All your company
templates should be saved in
this folder.

Startup Templates
These are templates that are
available to every user when
they open Word and often
contain macros or company
specific
customisations.
A
template that is saved in your
startup folder is considered to
be a global template (or add-in)
and
will
be
loaded
automatically every time Word
is opened. Create two subfolders in the “Startup Templates” folder. One will be for the current version of your
template called “Version 1” and the other will be for the next version of your template called “Next Version”.
Copy your startup template into the “Version 1” folder and also into the “Next Version” folder.

The reason for creating two folders both containing the same template is to make a clear distinction between
the current version and the version under development. The file in the “Version 1” folder is the live template
that everyone will be using. The file in the “Next Version” folder is the one you will edit when you need to
make changes. Once you have made your changes (and tested them) you just rename the “Next Version” folder
to “Version 2” and update the shortcut (see next page).
In preparation for the next set of changes create another folder called “Next Version” and copy across the
template from the “Version 2” folder. It is good practice to include the date as well as a version number in your
filenames.
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Creating Template
Template Shortcuts
There will always be some of your users in Word or that leave Word open so you need a method of updating
which doesn’t create locks on the actual templates. By using shortcuts instead of direct references you are able
to make changes without the users having to close Word first. When you want to update the template all you
need to do is to change the target path of the shortcut to point to a different template. Once the target path has
been changed the next time a user closes and reopens, the new template will be loaded instead.

Creating a shortcut for your startup template
You will need to create shortcuts for all your
templates although the process is identical regardless
of the type of template. First we need to create a
shortcut to your current template (the one saved in
your “Version 1” folder). In Windows Explorer open
the shared “Startup Templates” folder. In our example
this is:
S:\Shared Folder\Startup Template\
Right click in this folder and select (New > Shortcut).
Browse to the “Version 1” folder, select your template
and then press Next. In our example this is:
“StartupTemplate_Version1.dot”
Enter a name for the shortcut, making sure you
include the word “shortcut” to avoid any confusion
and press Finish. In this example we have used:
“StartupTemplate_Shortcut_Version1”

Two subfolders and a shortcut

At the end of all this you should have your final template saved in both the “Version 1” subfolder and the
“Next Version” subfolder (ready for future amendments) as well as a shortcut to the “Version 1” template.
Remember that it is the “Startup Templates” folder, not any of the subfolders that users will be using for their
startup directory.
We are almost there. The final step is to check that all your users are pointing to the right folders.
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Checking Template Locations
Once the templates have been saved and the corresponding shortcuts created the next step is to check that all
the users are pointing to the right locations. Users can easily check the template locations by displaying the
File Locations dialog box. In Word 2003 this can be displayed by selecting (Tools > Options)(File Locations
tab). In Word 2007 and 2010 this can be accessed from (Office > Word Options)(Advanced tab) and scrolling
to the File Locations button at the bottom of the dialog.
This dialog box allows you to check and modify the
folder paths of your template locations.

Pressing this button will display the File Locations tab.
To change the location of any of these templates select
the item and press the Modify button.

User Templates
C:\Documents and Settings\”username”\Application Data\Microsoft\Templates\
This should never be changed and should be pointing to the users Templates folder located on their C drive.

Workgroup Templates
S:\Shared Folder\Workgroup Templates\
This needs changing and should be pointing at the Workgroup Templates folder on your shared drive. This
contains the company’s general templates that are available from the New dialog box.

Startup Templates
S:\Shared Folder\Startup Templates\
This needs changing and should be pointing at the Startup Template folder on your shared drive. This contains
the shortcut you created earlier to your global template.
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